Installation der benötigten Pakete

Die folgenden Pakete werden benötigt:

  • apache2 - Der Apache Webserver in der Version 2
  • libapache2-mod-php5 - Das Apache-Modul für PHP5
  • php5 und php5-common - Den PHP-Interpreter
  • php5-gd - Die GD Grafikbibliothek für PHP5
  • php5-pgsql - Das PHP-Modul für den Zugriff auf die PostgreSQL Datenbank
  • php5-cli - PHP für die Kommandozeile, benötigt von drush
  • postgresql-8.1 - Der PostgreSQL Datenbankserver
  • phppgadmin - Webbasiertes Administrationswerkzeug für PostgreSQL(ähnlich phpmyadmin für mysql)

Die eigentliche Installation:

aptitude install apache2 libapache2-mod-php5 php5 php5-common php5-pgsql php5-gd php5-cli postgresql-8.1 phppgadmin